Welcome to Laser Pointer Forums - discuss green laser pointers, blue laser pointers, and all types of lasers



Is your arctic still functioning?

Is your Arctic still functioning?

  • Yes.

    Votes: 16 69.6%
  • No.

    Votes: 7 30.4%

  • Total voters
    23

Scottyzedinosaur

New member
Joined
Apr 4, 2010
Messages
263
Points
0
Just thought I'd open a poll, to have an idea of knowing how many peoples arctic is still working. Almost like a head-count.
Thanks for looking!
 



haveblue

New member
Joined
Sep 23, 2009
Messages
20
Points
0
I guess I lucked out. Mine still works perfectly. I ordered on 6/11 and it arrived on 8/18. I've only run about 4 AW2600 cycles through. I also removed the lens protector glass before ever turning it on.
 

udanis

Well-known member
Joined
Aug 2, 2010
Messages
1,131
Points
48
Mine worked fine till the day I sold it.....although my charger died.
 

W4NX

New member
Joined
Jun 28, 2010
Messages
32
Points
0
Mine still works, removed the filter from the training lens to eliminate reflections back into the diode and also picked up better batteries.
 

jeffreythe00

Well-known member
Joined
Jan 13, 2010
Messages
2,533
Points
63
i don't have an arctic, But if i did i'm sure it would not be functioning because i would have already thrown it out my window and probably damaged a neighbors car...... (not that any of that happened :whistle:)
 

MassLaserGuy

Member
Joined
Oct 4, 2010
Messages
42
Points
8
First post here. Arctic arrived 48 hours ago. Still works like new! :D
 
Last edited:

mikeeey

New member
Joined
Jun 7, 2007
Messages
1,771
Points
0
Haha I like this thread. My answer was no. But my Spartan is working PERFECT!
 

Hemlock_Mike

Well-known member
Joined
Jan 7, 2007
Messages
6,275
Points
83
I've had my Spyder Arctic for over two months now and it works like the day it arrived. It's a G1 model and it matches my two DIY lasers easy. The Spyder seems to have more heatsink mass and the driver does'nt go into temp overload and flash.
HMike
 

aryntha

Well-known member
Joined
Nov 17, 2009
Messages
2,033
Points
83
I have two.

One of mine has a problem with the "interlock pin" on the endcap not always making connection. (I don't count that as 'broken' but I would like to order a spare endcap from them if they'd ever answer my emails.) Rotating it some fixes that.

Besides that, no problems.
 

Hemlock_Mike

Well-known member
Joined
Jan 7, 2007
Messages
6,275
Points
83
Aryn----
Mine had the same problem at first. The safety pin wanted to pop out. I used my Dremmel tool and removed some plastic from the button and it's good to go now. A simple fix.

HMike
 




Top