Welcome to Laser Pointer Forums - discuss green laser pointers, blue laser pointers, and all types of lasers



Radiant X4: A LPM for the masses at Illumination Supply!

ImA4Wheelr

Member
Joined
Nov 28, 2013
Messages
123
Points
18
I broke down and ordered one along with a couple of those new XP-L emitters. Of course, my dumb ass forgot to order a cover. Oh well, next time I order I will add that to the cart.
 



Alex2893

Active member
Joined
Jun 6, 2014
Messages
402
Points
43
I seam to be having trouble downloading lightspeed. my computer thinks its a virus and removes it and a window pops up saying you do not have the permissions to download this program. im quite confused with this lol
 

ARG

Well-known member
Joined
Feb 27, 2011
Messages
6,893
Points
113
Which anti-virus do you have? It's definitely a false positive as it's coming up clean on jotti.
 

paul1598419

Well-known member
Joined
Sep 20, 2013
Messages
15,837
Points
113
Alex2893, Deja Vu! Boy, that takes me back. Do you happen to have Norton internet security? If so, you need to right click on the Norton logo, and turn off the firewall and the virus protection for about 15 to 30 minutes. Then download your Radiant Lightspeed. Pin that to your task bar in desktop, then you will need a program to open the driver package. I think I used "Wizard Tool" something or other. You can open the drivers but find a place to keep them as you will be doing this again. take my word for it. Good luck, Paul
 

ARG

Well-known member
Joined
Feb 27, 2011
Messages
6,893
Points
113
Well, there's your problem.

I didn't know people still used that :p

Microsoft makes a free anti-vrius, microsoft secuirty essentials, far less obstructive than anything else.
 

Alex2893

Active member
Joined
Jun 6, 2014
Messages
402
Points
43
i managed to download it and connect my meter to lightspeed but i cant get it to say 0.00 mw. its blank where its supposed to read it. it says i need to zero the meter to get 0.00mw to appear but when i click zero nothing happens
 

ARG

Well-known member
Joined
Feb 27, 2011
Messages
6,893
Points
113
Did you set the datastream protocol on the meter to Radiant? It has multiple protocols so it can be used with multiple programs.
 

paul1598419

Well-known member
Joined
Sep 20, 2013
Messages
15,837
Points
113
Alex, it sounds like you haven't loaded the driver package, yet. I used a program called "Device Driver Installation Wizard" to load mine. You need to do it with Norton's firewall and virus protection turned off. Then with the wizard program loaded you can load the driver package. If you are using Windows 8 use the driver called dpinst-amd64.exe and only that one. It will pop you into desktop where the wizard program will prompt you to got to 'next', and one of two drivers will be installed. that is all you need to do. then with your meter connected to your USB port click on the meter icon at the top left of the Radiant Lightspeed which should already be up and running in desktop and follow the icon out to meter connection and when you see the meter there click on it. Then you go to "graph" and click on it and start a new graph and name it. then go back to graph and click on to where the data is coming from, and that is "meter". Then you can start your data logging and it will prompt you to save it top a location. Etc. Good luck, Paul
 

Alex2893

Active member
Joined
Jun 6, 2014
Messages
402
Points
43
Thanks for the quick help guys, i really appreciate it :) Im going to give it a shot this weekend when i have more spare time. this meter already helped me out a bunch.

i bought a 520nm 501b from tmack he measured 202mw and when i got it i put in the battery backwards and turned it on for maybe 3/4 of a second. but it still worked and was so bright when i put the battery in right. so i put it on my meter tonight and im getting only 110mw :( so the battery reversal must have hurt something.
 

Alaskan

Well-known member
LPF Site Supporter
Joined
Jan 29, 2014
Messages
11,630
Points
113
Put one on ebay for 115 and I will buy it. PM me if you do.
 

csshih

Active member
Joined
Sep 27, 2010
Messages
431
Points
43
Let us know if you get the usb connection going!

Put one on ebay for 115 and I will buy it. PM me if you do.
We'll be looking into integrating ebay listings soon! Right now we're unfortunately tied up in other projects.
 

Alex2893

Active member
Joined
Jun 6, 2014
Messages
402
Points
43
Did you set the datastream protocol on the meter to Radiant? It has multiple protocols so it can be used with multiple programs.

This is what i missed. Thanks ARG it works !!!. This is fun.
I did a test on my (M140) Tmack Tmag :)

 

ARG

Well-known member
Joined
Feb 27, 2011
Messages
6,893
Points
113
Glad it works :). Don't forget to change it again if you plan to use other dataloggers!
 

Blarg King

New member
Joined
Oct 18, 2013
Messages
1,060
Points
0
Just placed an order for one! :D Glad this thread got brought back up, I've been dying for a LPM for ages but couldn't bring myself to pay so much for a laserbee!
 

RayJay

Banned
Joined
May 2, 2014
Messages
344
Points
0
Just a question, Is there a general LPF coupon like the CPF one? Or is there a LPF directed coupon just for the X4? Just wondering..
 




Top