Welcome to Laser Pointer Forums - discuss green laser pointers, blue laser pointers, and all types of lasers



Laser Pointer Store

JETLASERS(L@@K) For Sale EQ 635/400mW & 1W 445 Pl-E

hakzaw1

Well-known member
Joined
Apr 2, 2009
Messages
9,180
Likes
1,339
Points
113
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

The Ti- A was bad ass. wish i had mine back- Gray sent me a Ti -B in its place and the Ti-A is now very rare. I imagine JL repaired mine and sold it- the market for JLs there in China is HUGE- much bigger than USA- JL also does a lots of BIZ with law enforcement and the 'dazzler' series - non lethal weapons. And they make & sell lasers used for medical procedures. Gary tells me the guys who buy good lasers in China are obsessed with burning things.

cant get graphing drivers(for LightSpeed) to load tried 5 times tonite wth? stalls around half way. 6th try now- quit at 1,650/1,894 KB sooo close!!
 

phoenix77

New member
Joined
Apr 1, 2008
Messages
3,929
Likes
184
Points
0
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

You are doing ONE HECK OF A GREAT JOB on these laser comparison/reviews Hak :)
I & I'm sure Gray of JL. approve whole heartedly. Gray must really be pleased they are now posted !
Sorry for my electronics troubles Gray.... but Len has picked up the ball admirally. More info. in his post than one would normally get anywhere else & with a nice array of pics. too.
Well done Len & THANKS !!!
rob/phoenix77
 
Last edited:

hakzaw1

Well-known member
Joined
Apr 2, 2009
Messages
9,180
Likes
1,339
Points
113
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

n/p

I am still not able to use Peregrine and my prototype Radiant X4- hopefully my laptop with the soft that works will be fixed soon as i give up on trying ATM- Help has been generously been offered but has not really helped me much-- my fault .my bad.

I have dione LPM reading with an OLD- kenometer lite and an even older LB1- I think these lasers are being under-read by both of these and they have never been re-calibrated--

about the older JL switches- all tjhe plastic button switches (PL-Cs and PL -Es)
are less than ideal- they can get 'sticky' and make a few extra attempts to turn them on or off until one gets used to the ways that DO work- mashing the buttons is not the best way- when you want to turn these lasers off- a 'glancing' press works better-- if you think of the switch to be the center of a clock-face I come across from the 2 o'clock position down to 7 c'clock- these switches WILL work but not perfectly- I am not overly finicky with my lasers- IF you must have TOTAL PERFECTION do not buy any lasers from me. However if the switch completely fails... a fix can be had--but that will require shipping back to JL unless you or someone in USA can take apart and replace the switch- Gray will mail you a free replacement switch..

For the above reasons i only give a 7 for the switchs used in all Pl-Cs and Pl-Es.

I give a 10 to all the metal switches.(ProPL-E and the new EQs)

The switching used in the Ti-B is IMO not really a switch in the traditional sense as there is NO clicking at all-- I can this one a 'Piston Switch' a few thought thy had defective switches because they did not know how to properly replace the tail cap-

These work best if just before you replace the cap you press down on the spring which moves the 'piston' away from the battery-
so you tighten just enough til you see the laser 'flash' then loosen a little- at that point the tailcap 'should' function as a momentary switch- press the button and hold-
For continous 'ON" you merely tighten the tailcap until the laser stays on-
NOTE- be very sure you loosen the tail cap enough to not allow any momentray accidental lasing.
ALSO when replacing the tailcap be sure the laser is ALWAYS pointed in a safe direction as when you touch the caps edges to the host and the battery end it WILL come on as you have short-circuited the laser--

I give the switching on the Ti-B a 9.5
I would go with a ten EXCEPT for one small note... the tailcap spring is ONLY held in place by compression- careless handling 'COULD' cause this spring to fall out and maybe get lost-

So remember- press this spring just before putting the cap back on = take care where the laser is pointed (at all times IMO) and watch that the spring stays in place--N/P

As fas as safety features the PL-Cs were the closest to covering 'ALL the bases' lacking ONLY the delay start--shutter- removable key- tailcap 'dongle'

Most buyers opted to have the key removable in either position.... not wanting to have the key in place while using--the PL-C 635 400mW has key removeable.
 
Joined
Mar 28, 2011
Messages
1,633
Likes
207
Points
0
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

I don't like there tailcaps... PL-E pro

You can get more power from a penny then there tailcap design.

It has bin off ever since... becouse of this silly design flaw.

Just holding the tailcap in your hand, feeling it, feels cheap...

Not impressed at all ''yet'' even after a replacement tailcap, same current drawing flaw...

The unit is fine... but the tailcap makes me puke with the bad overused connections inside it. (or whatever the problem is) * i think tin won't cut it.

I don't put allot of bad energy towards company's.... but when i see one after having one, i can't help but to mention it.

My unit ''PL-E pro 800 can go over 1000mW with a simple coin connection, but with the tailcap installed it doesn't go over it nor on spec for the massive cooled head the diode sit's inside.

My second tailcap had the jackplug route disconnected.... but still then when having the jackplug off and the laser is functioning..... inserting the jackplug again results in fluctuation clearly visable when the connection shouldn't even be there. :tinfoil:

All i can say is Tailcap current flaw design...failure.

So for the people out there having a PL-E pro.... could you test (LPM) your unit without the tailcap..
 
Last edited:
Joined
Oct 13, 2010
Messages
340
Likes
25
Points
0
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

I'm just waiting on Jetlasers to start making 500mW+ 405nm PL-E Pros. I love my two 600mW greens, but I don't have a purple yet.
 

hakzaw1

Well-known member
Joined
Apr 2, 2009
Messages
9,180
Likes
1,339
Points
113
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

I don't like there tailcaps... PL-E pro

You can get more power from a penny then there tailcap design.
:(

Just holding the tailcap in your hand, feeling it, feels cheap...

:yabbem:

Not impressed at all ''yet'' even after a replacement tailcap, same current drawing flaw...

:undecided:

The unit is fine... but the tailcap makes me puke with the bad overused connections inside it. (or whatever the problem is) * i think tin won't cut it.

I don't put allot of bad energy towards company's.... but when i see one after having one, i can't help but to mention it.

My unit ''PL-E pro 800 can go over 1000mW with a simple coin connection, but with the tailcap installed it doesn't go over it nor on spec for the massive cooled head the diode sit's inside.

My second tailcap had the jackplug route disconnected.... but still then when having the jackplug off and the laser is functioning..... inserting the jackplug again results in fluctuation clearly visable when the connection shouldn't even be there. :tinfoil:

All i can say is Tailcap current flaw design...failure.

So for the people out there having a PL-E pro.... could you test (LPM) your unit without the tailcap..
***********************************************
the 'smilies' above are mine.



Bad newz but good to hear & know it- I will do the test on those I have here asap.
seems like almost none of the JL models are perfect. More feedback on this should cause Gray and JL to make whatever changes that are needed and send all owners a proper tailcap-- if Gray wants me to re-ship those to other CONUS owners I would be happy to do that-I doubt Gray would want the faulty ones back but if he does that can be cheaply mailed to me and I will send them all back to Gray in China in one big package . ---- I did find one faulty one that worked with the tailcap pin removed- not good!
:wtf:

If you are sending anything to me please note that rather than use 'CR' or C R Or C.R. use 'County Road ' instead. -as PPal shows CR etc as being
an invalid addy--

if you test your Pro Pl-E let Gray know the link where you posted your results (feel free to post them in this thread-)
AND until I can test the Pro PL-E 1100mW 445nm is temp. NFS.

I see no huge need to post any LPM pics unless you want to-

anyone had similar issues with the older PL-Es?? I have a few of those here and will test them as well.

TY Smeer--hak
:beer::thanks:
 

hakzaw1

Well-known member
Joined
Apr 2, 2009
Messages
9,180
Likes
1,339
Points
113
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

I don't like there tailcaps... PL-E pro

You can get more power from a penny then there tailcap design.

It has bin off ever since... becouse of this silly design flaw.

Just holding the tailcap in your hand, feeling it, feels cheap...

Not impressed at all ''yet'' even after a replacement tailcap, same current drawing flaw...

The unit is fine... but the tailcap makes me puke with the bad overused connections inside it. (or whatever the problem is) * i think tin won't cut it.

I don't put allot of bad energy towards company's.... but when i see one after having one, i can't help but to mention it.

My unit ''PL-E pro 800 can go over 1000mW with a simple coin connection, but with the tailcap installed it doesn't go over it nor on spec for the massive cooled head the diode sit's inside.

My second tailcap had the jackplug route disconnected.... but still then when having the jackplug off and the laser is functioning..... inserting the jackplug again results in fluctuation clearly visable when the connection shouldn't even be there. :tinfoil:

All i can say is Tailcap current flaw design...failure.

So for the people out there having a PL-E pro.... could you test (LPM) your unit without the tailcap..
___________________________

:beer: +5 to 'Smeer' you have given me another test i never thought to do.
I tested a just now returned Pro Pl-E 532 and with a 'penny' I got nearly double the output-- i do not know at all how this got by Gray- I sent him the LB II he now uses for graphs -- could it be the kind of issue that happen after being shipped??

I do not think JL makes much profit on GB lasers and when something like this or the poor quality IR filters happens (only on the 473s) I have no doubt whatsoever any profit there was is long gone.

Sorry you got a bad one Smeer- I got double the output from a 532 ProPL-E when NOT using the tail cap I also discovered a tailcap with the 'dongle' pin 'disabled' and another Pro PL-E tailcap that does not work at all..

So I suggest that any PL-E Pro owners do as 'Smeer' suggests see how much output you get when NOT using the tailcap..I assume there is a way to test the tailcap itself but I am not 100% sure how to do that with my DMM- can someone add this info here?? Am I correct thinking I need to check the resistance?? if so how? --

hak
 
Last edited:

Smeerworst

New member
Joined
Mar 28, 2011
Messages
1,633
Likes
207
Points
0
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

___________________________

:beer: +5 to 'Smeer' you have given me another test i never thought to do.
I tested a just now returned Pro Pl-E 532 and with a 'penny' I got nearly double the output-- i do not know at all how this got by Gray- I sent him the LB II he now uses for graphs -- could it be the kind of issue that happen after being shipped??

I do not think JL makes much profit on GB lasers and when something like this or the poor quality IR filters happens (only on the 473s) I have no doubt whatsoever any profit there was is long gone.

Sorry you got a bad one Smeer- I got double the output from a 532 ProPL-E when NOT using the tail cap I also discovered a tailcap with the 'dongle' pin 'disabled' and another Pro PL-E tailcap that does not work at all..

So I suggest that any PL-E Pro owners do as 'Smeer' suggests see how much output you get when NOT using the tailcap..I assume there is a way to test the tailcap itself but I am not 100% sure how to do that with my DMM- can someone add this info here?? Am I correct thinking I need to check the resistance?? if so how? --

hak
Indeed how do you test the resistance of the tailcap... :)

Thank you for confirming my problem Hak, and by the looks of it for many.

But now what...

The unit is fine, it's just the tailcap somehow...

Cheers :beer: Sm.
 
Last edited:

hakzaw1

Well-known member
Joined
Apr 2, 2009
Messages
9,180
Likes
1,339
Points
113
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

Kind of you to say-.... but the

thanks goes to you for letting me know of this. Gray tells me its being worked on- Their may be some kind of re-call or a replacement tailcap sent or offered. I just got a nice Pro Pl-E returned in perfect condition except, of course, it too has a bad tailcal causing it to be under spec a lot- As ATM I cannot use my best graphing meter ( untill my laptop is repaired) -- but using my old Kenometer Lite I see a huge diff. almost 3X more output when shorting at the tail. I saw a peak of 900mW-- But my best guess it that this black ProPl-- 532is a very solid over spec 700mW or more....It was sent to me ( from a USA buyer) to be returned to JL China but not for reasons about the laser's performance... I may hold it here for a new USA buyer once I get a proper tailcap for it, thus saving two more shipping costs. Technically its now used but I would have no qualms about selling it as nearly new. From now on checking for this will be SOP when I do tetsing and reviews of any handheld laser. A deserved +5 for the gentleman from the Netherlands.

v/r hak
 

IWIRE

New member
Joined
Dec 18, 2013
Messages
630
Likes
71
Points
0
Re: JETLASERS EQ 635/400mW & 1W 445 Pl-E

___________________________

I assume there is a way to test the tailcap itself but I am not 100% sure how to do that with my DMM- can someone add this info here?? Am I correct thinking I need to check the resistance?? if so how? --

hak
I have always had better "luck" doing a voltage drop test than by measuring resistance with problems like these. In this case you would probably have to use test leads with clips in order to measure it, which could induce it's own faulty readings. As long as they are good quality test leads with good clips it should work fine. You could probably put the switch in series with a test load to measure VD across it. Might be safer.

Guess I better test my switch. It might even be higher powered than I think :)

Voltage Drop Testing
 




Top