Welcome to Laser Pointer Forums - discuss green laser pointers, blue laser pointers, and all types of lasers



Laser Pointer Store

DX 200: Dilda - the aftermath.

herbicide

New member
Joined
Jun 23, 2007
Messages
23
Points
0
Black electricians tape. I was going to cut off a piece to burn, then I thought why bother, just burn a piece off!

Here's a macro shot of the aftermath.
 

Attachments


lazed

New member
Joined
Mar 15, 2008
Messages
70
Points
0
Looks cool. A vid would be nice too.

PS: How is the focus ring? I've heard some reports of it feeling unstable. Is this the case with yours?
 

herbicide

New member
Joined
Jun 23, 2007
Messages
23
Points
0
There is a bit of wobble, but I'm going to try teflon tape on it, that ought to tighten it up.

The tape above is thicker and duller than the usual stuff - it was advertised as fireproof.
 

GooeyGus

New member
Joined
Mar 8, 2008
Messages
2,673
Points
0
the head on mine was quite wobbly, but adding teflon tape made it feel perfect. No more wobble and its nice and smooth to focus
 

Switch

New member
Joined
Dec 9, 2007
Messages
3,327
Points
0
herbicide said:
There is a bit of wobble, but I'm going to try teflon tape on it, that ought to tighten it up.

The tape above is thicker and duller than the usual stuff - it was advertised as fireproof.
What happens if you try to burn it with a lighter? :-/
 

GooeyGus

New member
Joined
Mar 8, 2008
Messages
2,673
Points
0
So, is it just me or do these things suck down batteries like there's no tomorrow? My fresh panasonic CR2's from DX lasted two days in this thing. I mean, yea I was using it a lot but not THAT much. I thought the thing actually had something wrong with it because all the sudden it just dimmed out, and the batteries still felt pretty strong (the tongue test... lol). Popped in a fresh pair when I got home and all was well again.
 

BoostCrzy

New member
Joined
Mar 4, 2008
Messages
39
Points
0
gotta check the contacts on the switch.....some seem to have connection issues there...my batteries are running on average 20-30 totally minutes run time before they show any signs of weakening...
 

GooeyGus

New member
Joined
Mar 8, 2008
Messages
2,673
Points
0
well it probably had about 30 minutes total run time on it... but they never showed signs of weakening. It was working fine and burning, and then all the sudden it just faded out. Then I would let it sit for a few mins, turn it back on, and it would be strong for about 5 seconds and then fade out. The contact looks fine but I am going to add some solder to it as well. But it also had the same symptom when I bypassed the switch. When I replaced the batteries all was fine again. Maybe i'm just not used to the run time on it, since this is my first high power red.
 

Benm

Well-known member
Joined
Aug 16, 2007
Messages
8,112
Points
113
I guess its just the batteries then. I've measured the thing consuming around 300 mA, which should give you up to 2 hours on full CR2's, but perhaps they werent full or not of good quality.
 

Gazoo

Active member
Joined
Jun 9, 2007
Messages
3,199
Points
38
Benm said:
I guess its just the batteries then. I've measured the thing consuming around 300 mA, which should give you up to 2 hours on full CR2's, but perhaps they werent full or not of good quality.
Interesting....since it is drawing 300ma's it should be putting out close to 200mw's. Sounds like a good deal.
 




Top